We are currently experiencing interruptions to some Visier services.
Incident Report for Visier Inc.
Resolved
Please note that some customers may have recently experienced an interruption or other issue with their Visier services. At this time, the issue has been resolved and services are fully restored. We apologize for any inconvenience this may have caused. Thank you for your patience.
Posted Jul 17, 2020 - 15:07 PDT
Investigating
Please note that some customers may currently be experiencing an interruption to their Visier services. We are actively working on resuming all services back to normal. We apologize for any inconvenience this may have caused. Thank you for your patience.

Next update (estimated): {2020-07-17 3:30 PM PST}
Posted Jul 17, 2020 - 14:54 PDT
This incident affected: Workforce Analytics (US, Canada, Europe) and Visier People (US, Canada, Europe).