We are currently experiencing an issue with the connectivity to our services.

Incident Report for Visier Analytics

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:25 UTC

Monitoring

Our provider has implemented a fix, and connectivity has been restored.
Posted Dec 05, 2025 - 09:21 UTC

Investigating

Please note that some customers may be experiencing connectivity errors. The problem originates from one of our service providers. We are actively working with them on resolving the issue. We apologize for any inconvenience, and we thank you for your patience.
Posted Dec 05, 2025 - 08:50 UTC
This incident affected: Visier API (US, Canada, Europe, APAC), Visier Smart Compensation (US, Canada, Europe), Visier Compensation Benchmarks (US), and Visier People (US, Canada, Europe, APAC).