We are currently experiencing an issue with the Data Upload and Data Transfer functionality.

Incident Report for Visier Analytics

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 06:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 05:31 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2025 - 04:00 UTC

Investigating

Please note that some customers may be experiencing issues when accessing the Data Transfer room in Visier People Studio. We are actively working on resolving the issue. We apologize for any inconvenience this may have caused.
Thank you for your patience.
Posted Apr 24, 2025 - 03:05 UTC
This incident affected: Visier People (US, Canada, Europe, APAC).