We are currently experiencing an issue accessing previous Pay Cycles in Smart Compensation.

Incident Report for Visier Analytics

Resolved

The incident has been resolved, thank you for your patience.
Posted Mar 13, 2025 - 16:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2025 - 15:11 UTC

Identified

Please note that some customers may be experiencing issues accessing previous Pay Cycles in Smart Compensation. We are actively working on resolving the issue. We apologize for any inconvenience this may have caused. Thank you for your patience.
Posted Mar 13, 2025 - 02:05 UTC
This incident affected: Visier Smart Compensation (US, Europe).