We are currently experiencing a performance issue with Vee in the EU region.

Incident Report for Visier Analytics

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 04:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2025 - 04:32 UTC

Identified

Please note that some customers may currently be experiencing a performance issue with Vee in our EU region. We are actively working on resolving the issue. We apologize for any inconvenience this may have caused.
Posted Aug 27, 2025 - 04:10 UTC