We are currently experiencing interruptions to some Visier services.
Incident Report for Visier Inc.
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 08:01 PDT
Monitoring
Please note that some customers may currently be experiencing an interruption to their Visier services. We are actively working on resuming all services back to normal. We apologize for any inconvenience this may have caused. Thank you for your patience.
Posted Apr 26, 2021 - 07:54 PDT
This incident affected: Visier People (US).